Vulnerability feed
CONTRIBUTE

Vulnerability

warn

CVE-2022-28806

Reference to the description:

https://nvd.nist.gov/vuln/detail/CVE-2022-28806

Description:
An issue was discovered on certain Fujitsu LIEFBOOK devices (A3510, U9310, U7511/U7411/U7311, U9311, E5510/E5410, U7510/U7410/U7310, E459/E449) with BIOS versions before v1.09 (A3510), v2.17 (U9310), v2.30 (U7511/U7411/U7311), v2.33 (U9311), v2.23 (E5510), v2.19 (U7510/U7410), v2.13 (U7310), and v1.09 (E459/E449). The FjGabiFlashCoreAbstractionSmm driver registers a Software System Management Interrupt (SWSMI) handler that is not sufficiently validated to ensure that the CommBuffer (or any other communication buffer's nested contents) are not pointing to SMRAM contents. A potential attacker can therefore write fixed data to SMRAM, which could lead to data corruption inside this memory (e.g., change the SMI handler's code or modify SMRAM map structures to break input pointer validation for other SMI handlers). Thus, the attacker could elevate privileges from ring 0 to ring -2 and execute arbitrary code in SMM.
Last updated date:
05/18/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
05/18/2022
Reference url to background

https://www.binarly.io/advisories

Vulnerability FeedContributorsAbout

@inTheWild

©2022

Privacy Policy