logo
Vulnerability feed
CONTRIBUTE

Vulnerability

warn

CVE-2021-39144

Reference to the description:

https://nvd.nist.gov/vuln/detail/CVE-2021-39144

Description:
XStream is a simple library to serialize objects to XML and back again. In affected versions this vulnerability may allow a remote attacker has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. XStream 1.4.18 uses no longer a blacklist by default, since it cannot be secured for general purpose.
Last updated date:
01/20/2023

Reports

alt

ACTIVELY EXPLOITED

Type:
exploitation
Confidence:
HIGH
Date of publishing:
03/06/2023
Reference url to background

https://securityonline.info/hackers-are-actively-exploiting-cve-2022-31678-cve-2021-39144-in-the-wild/

Type:
exploitation
Confidence:
HIGH
Date of publishing:
03/10/2023
Type:
exploit
Confidence:
HIGH
Date of publishing:
08/27/2021
Type:
exploit
Confidence:
HIGH
Date of publishing:
10/31/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
01/20/2023
Vulnerability FeedContributorsAboutBlog

@inTheWild

©2023

Privacy Policy