Vulnerability feed
CONTRIBUTE

Vulnerability

warn

CVE-2022-24112

Reference to the description:

https://nvd.nist.gov/vuln/detail/CVE-2022-24112

Description:
An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.
Last updated date:
05/11/2022

Reports

alt

ACTIVELY EXPLOITED

Type:
exploitation
Confidence:
HIGH
Date of publishing:
08/25/2022
Reference url to background

https://www.cisa.gov/known-exploited-vulnerabilities-catalog

Type:
exploit
Confidence:
HIGH
Date of publishing:
02/22/2022
Reference url to background

https://github.com/Mr-xn/CVE-2022-24112

Type:
exploit
Confidence:
HIGH
Date of publishing:
02/22/2022
Reference url to background

https://github.com/Udyz/CVE-2022-24112

Type:
exploit
Confidence:
HIGH
Date of publishing:
02/25/2022
Reference url to background

https://github.com/Axx8/CVE-2022-24112

Type:
exploit
Confidence:
HIGH
Date of publishing:
03/08/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
03/16/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
03/20/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
05/11/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
05/11/2022
Vulnerability FeedContributorsAboutBlog

@inTheWild

©2022

Privacy Policy