Vulnerability feed
CONTRIBUTE

Vulnerability

warn

CVE-2022-44784

Reference to the description:

https://nvd.nist.gov/vuln/detail/CVE-2022-44784

Description:
An issue was discovered in Appalti & Contratti 9.12.2. The target web applications LFS and DL229 expose a set of services provided by the Axis 1.4 instance, embedded directly into the applications, as hinted by the WEB-INF/web.xml file leaked through Local File Inclusion. Among the exposed services, there is the Axis AdminService, which, through the default configuration, should normally be accessible only by the localhost. Nevertheless, by trying to access the mentioned service, both in LFS and DL229, the service can actually be reached even by remote users, allowing creation of arbitrary services on the server side. When an attacker can reach the AdminService, they can use it to instantiate arbitrary services on the server. The exploit procedure is well known and described in Generic AXIS-SSRF exploitation. Basically, the attack consists of writing a JSP page inside the root directory of the web application, through the org.apache.axis.handlers.LogHandler class.
Last updated date:
11/23/2022
Type:
exploit
Confidence:
HIGH
Date of publishing:
11/23/2022
Reference url to background

https://members.backbox.org/maggioli-appalti-contratti-multiple-vulnerabilities/

Vulnerability FeedContributorsAboutBlog

@inTheWild

©2022

Privacy Policy